Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2025 - 09:00 CET
Scheduled
We will be undergoing a scheduled maintenance during this time that should only last a few minutes. These maintenance is helpful to improve the genera performance and stability of the system.
Posted Feb 28, 2025 - 15:14 CET
This scheduled maintenance affected: Dashboard, iOS Apps, Android Apps, API, Masked communication, and Label & pdf generation.