Degraded Perfomance

Incident Report for MotionTools

Resolved

After we shipped the fix, the performance quickly improved. Full access to the dashboard was restored for all customers at 19:50.
Posted Oct 26, 2025 - 21:21 CET

Monitoring

While overall system stability has already recovered quickly after the measures we took at 18:37, we identified the actual issue inside of the dashboard and shipped a fix. We will soon start to gradually re-enable dashboard access and continue to monitor the overall performance.
Posted Oct 26, 2025 - 19:10 CET

Update

The issue was identified and as overall system stability started to suffer, we temporarily disabled access to the dashboard for some customers with heavily load to ensure that drivers can continue to work.
Posted Oct 26, 2025 - 18:37 CET

Investigating

Customers currently may experience degraded dashboard performance. We're looking into it.
Posted Oct 26, 2025 - 18:17 CET
This incident affected: Dashboard.